How to build Exploring Android Master project or subproject

from the CommonsWare Community archives

At March 19, 2020, 8:05pm, Jan asked:

I’ve been using Android Studio so I skipped over the setup and configuration of studio and emulator in the Exploring Android book. I run projects on the AVD all the time so I know it works.

I opened the cw-andexplore-master project but Studio doesn’t offer a rebuild project build option for it.

I also tried just opening T02-Project but again no way to build it.

The Rebuild project option shows just fine with the Room master. I was able to Clean and Compile(Rebuild) it just fine (didn’t actually try running it on emulator).

I’ve attached a few screenshots so you can see what I mean. Okay just found out I can only put 1 image as a new user. So showing only 1.

At March 19, 2020, 8:24pm, mmurphy replied:

You imported two directory levels too high. Pick a tutorial that you want to start with (say, T02-Project/). In there is a ToDo/ directory. Choose that when importing via File > New > Import Project.

The Exploring Android repository is unusual, because:

So, each top-level directory (e.g., T02-Project/) contains a copy of the actual project (ToDo/) as of when that particular tutorial’s steps were completed.